Quinyx system requirements

Updated 1 month ago by Leigh Hutchens

Many different factors contribute to the perceived performance of a web application, e.g. hardware configuration, installed software and network infrastructure. This document specifies hardware and software requirements pertaining to the use of Quinyx, with the reservation that even if the mentioned requirements are met, other external factors may also contribute to the performance of the application.

Network Requirements

Network Requirements

Quinyx uses the AMFPHP binary protocol for client-server communication. Binary data is compact in size, which means that the application is often perceived as faster than normal web pages; however, the application and its framework must be downloaded once upon initial startup, after clearing the browser cache, or after an application update. The application is over 5MB in size and may take some time to download, depending on the client’s internet connection.

Data communication

Quinyx communicates through SSL and requires both port 80 and 443 to be open to the internet.

Internet Connection

The Quinyx platform, including both web applications and mobile apps, requires unrestricted access to the wildcard DNS record *.quinyx.com.

An internet connection of at least 1 Mbit/s is recommended for using Quinyx without significant slowdowns. The slower the connection, the longer the application download will take and the longer it will take to load views with large amounts of data, i.e. schedules spanning long periods, attest views, etc.

Quinyx Classic (Flash client)

Hardware Requirements

Below are the minimum and recommended client hardware configurations for running Quinyx. Note that CPU performance is the most important factor in rendering time of views in the application, and we therefore highly recommend high-end CPUs when working in units with more than 20 employees.

Minimum

CPU

1,6 Ghz Intel/AMD or equivalent. 1MB level 2 cache.

RAM

2 GB

Screen Resolution

1280 x 800

CPU

Intel® Core™ i7-2637M 1,7 – 2,8 Ghz. 4MB level 2 cache.

RAM

4 GB or greater

Screen Resolution

1600 x 1200 or greater

Software Requirements

Below are the recommended software configurations for running Quinyx. As the software is web based it does not have any specific software dependencies other than a browser with Adobe Flash installed.

Operating Systems

The following operating systems have been tested with success.

Windows XP SP3

Windows Vista

Windows 7

Windows 8 (desktop mode only)

Windows 10

Mac OS X 10.6 Snow Leopard

Mac OS X 10.7 Lion

Mac OS X 10.8 Mountain Lion

Mac OS X 10.9 Mavericks

Mac OS X 10.10 Yosemite

Linux Ubuntu 12.04

Linux Ubuntu 13.04

Web Browsers

The following web browsers have been tested with success. Be aware that certain combinations of web browser and Adobe Flash updates can lead to temporary quirks with Flash applications.

Supported

Browser

Notes

Internet Explorer 8

Will not be supported after 28 February 2020 due to lack of TLS 1.2 support.

Internet Explorer 9

Will not be supported after 28 February 2020 due to lack of TLS 1.2 support.

Internet Explorer 10

Will not be supported after 28 February 2020 due to lack of TLS 1.2 support.

Internet Explorer 11

Microsoft Edge

Chrome 78 +

Firefox 70+

Safari 12

Adobe Flash

Quinyx WFM is built on the Apache Flex framework which is dependent on Adobe Flash.  We always recommend the latest version of Adobe Flash for each respective browser. At the time of writing, the latest version of Flash is 32.0.0.293, which has the following system requirements.

Windows
  • 32- and 64-bit (unless noted): Microsoft® Windows® XP SP3 (32-bit), Windows Vista® (32-bit), Windows 7, Windows 8.1 and Windows 10
  • Latest versions of Microsoft Internet Explorer, Microsoft Edge, Mozilla Firefox, Google Chrome and Opera
Mac OS
  • Mac OS X v10.10 or later
  • Latest versions of Safari, Mozilla Firefox, Google Chrome, and Opera
Linux  
  • YUM, TAR.GZ, RPM and APT packages for NPAPI and PPAPI
  • Latest versions of Firefox or Google Chrome 

Webpunch

Webpunch is an HTML5-based interface for punching in and out, and can be used as an alternative to dedicated punching clocks. It is built to work on modern hardware solutions such as desktop computers, tablets, smart terminals and PoS systems.

Hardware requirements

Webpunch is based on an HTML5/Javascript framework and requires modern hardware with full HTML5 and Javascript support.

Minimum

Web Punch is built to work on tablets as well as traditional desktop platforms, however, it requires high-performance mobile CPUs in order to guarantee optimal rendering speed. We therefore recommend the latest readily available ARM-based CPU architecture.

CPU

Snapdragon 800 series (or equivalent ARMv7-based)

RAM

2 GB

Screen Resolution

1024 x 768

Connectivity

Ethernet or Wi-Fi with internet access

When run in a traditional desktop environment, we recommend the latest CPU architecture in order to ensure long-term forward compatibility.

CPU

Intel® Core™ i5 – i7

RAM

4 GB or greater

Screen Resolution

1366 x 768 or greater

Connectivity

Ethernet or Wi-Fi with internet access

Software requirements

Web Punch is based on an HTML5/Javascript framework and requires modern software platform with full HTML5 and Javascript support.

Web browsers (desktop operating system clients)

Internet Explorer 11

Chrome 39+

Firefox 34+

Safari 6

Safari 7

Safari 8

Neo

Neo is the next generation of the Quinyx web client and is based on HTML5 and Javascript. At the time of writing it consists of the a Schedule/Time view and a People view.

Neo is built to work on tablets as well as traditional desktop platforms, however it requires high-performance mobile CPUs in order to guarantee optimal rendering speed. We therefore recommend the latest readily available ARM-based CPU architecture.

Hardware requirements

Minimum

CPU

Snapdragon 801 (or equivalent ARMv7-based)

RAM

2 GB

Screen Resolution

1024 x 768

Connectivity

Ethernet or Wi-Fi with internet access

When run in a traditional desktop environment, we recommend the latest CPU architecture in order to ensure long-term forward compatibility.

CPU

Intel® Core™ i5 – i7

RAM

4 GB or greater

Screen Resolution

1366 x 768 or greater

Connectivity

Ethernet or Wi-Fi with internet access

Software requirements

Neo is based on an HTML5/Javascript framework and requires modern software platform with full HTML5 and Javascript support.

Supported web browsers

Microsoft Edge

Microsoft Internet Explorer

Google Chrome

Mozilla

Firefox

Apple Safari

Desktop

No*

IE 11

Latest version**

No*

No*

Mobile

No

No

Latest version**

No

Latest version**

Tablet

No

No

Latest version**

No

Latest version**

Notes:

* Support of desktop browsers Microsoft Edge, Mozilla/Firefox and Apple Safari is not supported due to low usage in our customer base.

** “Latest version” is defined by the browser supplier.

Mobile apps

Quinyx has mobile apps for iOS and Android.

Hardware requirements

There are no specific hardware requirements. Quinyx mobile apps will work on any hardware as long as they are running the minimum required version of the operating system in question.

Software requirements

The minimum required operating system version is always specified in Google Play and App Store. In order to guarantee the highest level of functionality and security, we will continually update to the latest versions of Apple’s and Google’s OS APIs and frameworks, which means the minimum required operating system version will increase over time, however we strive to always support the most commonly used versions of each operating system.

Quinyx mobile on Google Play

Quinyx mobile on App Store


How Did We Do?